Partial Outage

Incident Report for Ribbon Health

Resolved

This incident has been resolved.
Posted Mar 26, 2025 - 16:20 EDT

Monitoring

We experienced brief incidents and periods of latency in our Providers endpoint this morning and are monitoring.
Posted Mar 26, 2025 - 12:19 EDT
This incident affected: Providers Endpoint (Provider Search).